RoboTrack

Elektronik - Projekte Live Webcam - Steuerung mit Server AVR Servo Relais

Logo RoboTrack
Dienstag, 26. September 2017
Start Einloggen Einloggen Die Mitglieder Das Foren-Team Suchfunktion
1120 Beiträge & 102 Themen in 9 Foren
Keine neuen Beiträge, seit Ihrem letzten Besuch am 26.09.2017 - 14:48.
  Login speichern
Forenübersicht » Bluetooth Modul BTM 222 Basisboard » BTM-mini-S v2.3 Modul

vorheriges Thema   nächstes Thema  
43 Beiträge in diesem Thema (offen) Seiten (3): (1) 2 3 weiter >
Autor
Beitrag
SupTom ist offline SupTom  
BTM-mini-S v2.3 Modul
23 Beiträge - Grünschnabel
Hallo

ich habe jetzt ein BTM-mini-S v2.3 Modul aufgebaut, ich habe BTM Modul F/W Version v6,28, ich kann das Modul am PC über AT einstellen, ich habe Funkkontakt,

ich habe von Conrad ein Temp Logger Best Nr. 559619 angeschlossen. Bei der Datenübertragung kommen nur Kryptische Zeichen an als ob die falsche Baudrate eingestellt ist, ändere ich die Baudrate bleiben die Zeichen gleich egal welche Baudrate ich einstelle, immer die gleichen Zeichen.

Mit einem anderen BTM Modul welches ich mir mal vor zwei Jahren auf eine Lochplatine gebastelt hatte ohne den 74HCT14 geht es, kann ich da an der Einstellung noch was ändern oder muss ich einen inverter dazwischen schalten oder kann ich den 74HCT14 weglassen ?

Ich bin mit mein Latein am Ende, hat einer vielleicht eine Idee ?

SupTom
Beitrag vom 04.03.2015 - 14:57
Diesen Beitrag melden   nach weiteren Posts von SupTom suchen SupTom`s Profil ansehen SupTom eine E-Mail senden SupTom eine private Nachricht senden SupTom zu Ihren Freunden hinzufügen zum Anfang der Seite
Fennec ist offline Fennec  
Administrator
1220 Beiträge - Hardcoreposter
Fennec`s alternatives Ego
Poste bitte mal die Einstellungen vom BTM222.

Hast Du zu dem Conrad Modul ein Schaltbild ? Die Infos auf der Conrad Seite sind sehr duerftig. Da steht zum Beispiel das es direkt an die RS232 angeschlossen werden soll. Also ein voellig andres Protokoll, als das was das BTM222 braucht.

Auf den Bildern die ich dazu finde ist nichts zu erkennen.

Ideal waere ein Schaltbild von dem Logger.

Versuche mal zu entziffern um was fuer einen Mikrocontroller es sich handelt oder poste einfach mal alles was Du darauf entziffern kannst. Rechts der Kleine wird ein EEPROM sein, der ist uninteressant.

Du schreibst das es mit einem selbstgebastelten BTM222 geht. Hast Du auf der Platine auch einen 74HCxx oder ist da ein MAX232 drauf ?




.
Keine Interessen, kein Spezialwissen, keine persoenlichen Daten, keine Hobbies oder Vorlieben.

Aber: T-DSL..... sauschnell
Beitrag vom 05.03.2015 - 00:53
Diesen Beitrag melden   nach weiteren Posts von Fennec suchen Fennec`s Profil ansehen Fennec eine private Nachricht senden Fennec zu Ihren Freunden hinzufügen zum Anfang der Seite
SupTom ist offline SupTom  
Protokoll
23 Beiträge - Grünschnabel
Hallo Fennec

Ja das ist richtig mit dem Forum, ich muss mich da erst mal einarbeiten, ich hatte den Text erst mal im falschen Tema abgelegt.

Leider habe ich keine Schaltplan für den Datenlogger, der große Chip ist ein ATTINY 84
der kleine ein ATMLH216

auf meiner Lochplatine habe ich einen MAX2323 mit dem geht das

das ist das was ich vom BTM bekomme:

Šú£•¿¯y­¿›Ÿ›¿yyyUSÒ
Šú£•¿¯y­¿›Ÿ›¿y!#7¿u'59#-9¿Yuå¯W5%­£¿-#¿q7¿y5'-§
­åås§#)-!#¿=5/'5#¿IŸ££‘E‹å埋¿Y­yUSÒ
Šú£•¿¯y­¿›Ÿ›¿y!#7¿uyyUSÒ

7¿u'59#-9¿Yuå¯W5%­£¿-#¿q7¿y5'-§­åås§#)-!#¿=5/'5#¿IŸ££‘E‹åyyUSÒ
Šú£•¿¯y­¿›Ÿ›
¿y!#7¿u'59#-9¿Yuå¯WyyUSÒ
Šú£•¿¯y­¿›Ÿ›¿y!#7¿u'59#-9¿Yuå¯W5%­£¿-#¿q7¿y5'-§­åås
§#)-!#¿=5/'5#¿IŸ££‘E‹ååŸyyUSÒ
Šú£•¿¯y­¿›Ÿ›¿y!#7¿u'59#-9¿Yuå¯W5%­£¿-#¿q7¿y5'-
§­åås§#)-!#¿=5/'5#¿IŸ££‘E‹å埋¿Y­9/5¡g=#1§=15¿I7Eå‹¿e555¿XZ^iåiåiåiå
yyUSÒ
Šú£•¿¯y­¿›Ÿ›¿y!#7¿u'59#-9¿Yuå¯W5%yyUSÒ
Šú£•¿¯y­¿›Ÿ›¿y!#7¿u'59#-9¿Yuå¯W5%
­£¿-#¿q7¿y5'-§­yyUSÒ
Šú£•¿¯y­¿›Ÿ›¿y!#7¿u'59#-9¿Yuå¯W5%­£¿-#¿q7¿y5'-§­
das sollte kommen:

Templog 2.5 (C) 2012 Conrad Electronic SE
(Temp. in Grad Celsius)

Funktion waehlen [0..7]:

0: Sprache/Language [d]
1: Messwerte anzeigen
2: Messwerte anzeigen und aufzeichnen
3: Aufgezeichnete Messwerte anzeigen
4: Dezimal-Trennzeichen [,]
5: ADC an [n]
6: ADC kalibrieren
7: Messintervall Sekunden [5]

und das ist die Einstellung BTM:

ATI1
OK
ATC=0, NONE FLO
ATD=0000-00-000000, NEVER SET BLUETOOTH ADDRESS
ATE=1, ECHO CHARACTERS
ATG=0, NEVER ENTER SLEEP MODE
ATH=1, DISCOVERABLE
ATK=0, ONE STOP BIT
ATL=2, BAUD RATE is 19200
ATM=0, NONE PARITY_BIT
ATN=logger3, LOCAL NAME
ATO=0, ENABLE AUTO CONNECTING
ATP=1234, PIN CODE
ATQ=0, SEND RESULT CODE
ATR=1, SPP SLAVE ROLE
ATS=1, ENABLE AUTO-POWERDOWN OF RS232 DRIVER
ATX=1, ALWAYS CHECK '+++'

am PC ich habe einen Belkin USB
ich habe mal ein BTM als Master und ein als Slave gekoppelt, da kommen auch nur diese Zeichen
ich habe jetzt mal die zwei freien Pegelwandler in die RXD Leitung gelötet,
geht auch nicht,
dann habe ich einen Pegelwandler in der TXD Leitung mal kurz geschlossen, geht auch nicht
und den MAX bekomme ich ja nicht auf die Platine, ist Pegelwandler nicht gleich Pegelwandler ?
Beitrag vom 05.03.2015 - 10:28
Diesen Beitrag melden   nach weiteren Posts von SupTom suchen SupTom`s Profil ansehen SupTom eine E-Mail senden SupTom eine private Nachricht senden SupTom zu Ihren Freunden hinzufügen zum Anfang der Seite
Fennec ist offline Fennec  
Administrator
1220 Beiträge - Hardcoreposter
Fennec`s alternatives Ego
Hi,

das BTM muss so funktionieren. Die Einstellungen sind okay.
Mit Dem ATTiny 84 kann man auch was anfangen. Datenblatt gibt es bei Atmel

http://www.atmel.com/Images/doc8006.pdf

Dann guckst Du auf welcher Spannung der Tiny laeuft. Bei 3V uebergehst Du den 74HCxx und schliesst den µC direkt an das BTM222 Modul an. TXD / RXD natuerlich kreuzen.
Bei 5V wofuer das BTM222 Modul mit dem 74HCXX ursprunglich ausgelegt ist., also um mit µC zu kommunizieren, laesst Du den drin.

Der MAX 232 oder MAX 2323 wandelt nur unnoetig um. Doppelt gemoppelt und das gibt natuerlich Fehler.

Also ganz simple.

Auf der Platine vom Logger zurueck verfolgen wo TXD und RXD am µC anliegen. Bauteile dazwischen einfach uebergehen.
Messen was der µC vom Logger fuer eine Spannung hat..
Bei 3V den 74HCxx weg lassen, bei 5V drin lassen.

Das war eigentlich schon alles.

Dein Problem wird sein das der Logger einen Chip hat, wie z.B. den MAX232, der den "richtigen" RS232 Pegel setzt. Also so wie es im Datenblatt, wenn man den Mist so nennen darf auch steht. Das ist KEIN TTL Pegel sondern ein RS232 Protokoll, geht also auch in's Negative und das "versteht das BTM222 einfach nicht.

Ziemlich simple, nur schlecht zu erklaeren.

Du gehst also quasi mit dem BTM222 direkt an die Beinchen vom µC auf Deinem Logger.

Nebenher. Kaufe Dir ein Programmiergeraet fuer 5.-, dann kannst Du diese Logger in Massen kopieren und brauchst nicht den teuren Kram vom blauen C. (habe ich gefressen sry)

Fuer den Arduino, der nichts anderes ist als ein Atmel µC auf einer Platine haettest Du es sogar noch billiger und gleich mit Quelltext dazu. Kannst also Deine eigenen Ideen einbringen ohne gross C lernen zu muessen.
Solch ein AVR (Atmel µC) kostet vielleicht 50 cents. Auf Lochraster gepappt, DS1820 dran und Du hast einen Logger fuer 2.-
Nicht lange her brauchte ich genau sowas, aber mit einer Aufloesung von 1/10°C. eben runter geladen, auf einen AVR gepappt, fertig. Sogar gleich mit LCD.

/Edit

http://www.dl8ma.de/Arduino/Thermometer_Dallas_ds1820/

Das habe ich in vielleicht 30min fuer nicht mal 5.- nachgebastelt.. Wenn man ein halbwegs gescheites Programmiergeraet hat, geht sowas ruck zuck fuer ganz wenig Geld.









.
Keine Interessen, kein Spezialwissen, keine persoenlichen Daten, keine Hobbies oder Vorlieben.

Aber: T-DSL..... sauschnell


Dieser Beitrag wurde 1 mal editiert, zuletzt von Fennec am 05.03.2015 - 12:47.
Beitrag vom 05.03.2015 - 12:25
Diesen Beitrag melden   nach weiteren Posts von Fennec suchen Fennec`s Profil ansehen Fennec eine private Nachricht senden Fennec zu Ihren Freunden hinzufügen zum Anfang der Seite
SupTom ist offline SupTom  
23 Beiträge - Grünschnabel
Hallo Fennec

der Logger arbeitet mit 5 Volt, auf der Platine ist ein Programmieranschluß
da habe ich TxD und RxD abgegriffen und ans BTM angeschlossen
jetzt kommt die Übertragung in Deutsch,

aaaaber jetzt habe ich das gleiche Problem wie bei meiner Lochplatine

ich habe eine mit Transistoren als Pelwandler und eine mit MAX3232
mit MAX geht,
mit Transistor kommen immer nur die ersten zwei oder drei Zeilen und die laufen dann immerzu bis ich den Logger ausschalte

wer ist für die Pegelwandlung zuständig der Tiny84 oder der ATMLH für den habe ich kein Datenblatt gefunden

also werde ich wohl nicht umhin kommen einen MAX dazwischen zu schalten

dieser Pegelwandler

http://robotrack.org/include.php?path=article&...tentid=231
Platinenmaße: 31x17 mm

ist da ein MAX3232 drauf ? Wenn ja hast du da noch Leiterplatten ?

Das mit dem Arduino Board liegt schon seit zwei Jahren in meiner Bastelkiste
da muss ich mich doch mal damit beschäftigen;-) aber die Zeit

erstmal besten Dank für die schnelle Hilfe
Beitrag vom 05.03.2015 - 14:30
Diesen Beitrag melden   nach weiteren Posts von SupTom suchen SupTom`s Profil ansehen SupTom eine E-Mail senden SupTom eine private Nachricht senden SupTom zu Ihren Freunden hinzufügen zum Anfang der Seite
Fennec ist offline Fennec  
Administrator
1220 Beiträge - Hardcoreposter
Fennec`s alternatives Ego
Noe, schliess das mini BTM direkt an den µC an. Der hat ja 5V TTL, das passt dann.
Du brauchst definitiv keinen Pegelwandler a la MAX 232 oder sowas.
Wenn Du das BTM222 doch konfiguriert, bzw,. ausgelesen hast, musst Du ja ein passendes TTL Datenkabel haben. Schliesse das doch mal direkt an das Temperaturmodul an. Also TX auf RX, RX auf TX und GND auf GND. Wenn das dann auch nicht geht, kann es ja nur das Modul selbst oder die Einstellungen im Terminal sein.
Wenn das dann geht, stellst Du eine Verbindung mit dem BTM222 her. Also NUR das BTMmini OHNE Logger und mit dem PC pairen. Dann am BTM222 RXD und TXD verbinden. Nennt man loop back. So muessen ja dann di e Zeichen die Du im Terminal eingibst genau so wieder zuerueck kommen.
So laesst sich der Fehler meiner Meinung nach am einfachsten finden.

Was dieses ATMLH fuer ein Ding ist weiss ich auch nicht, muesstest Du mal reverse engineerenverwirrt)
Ich tippe aber mal auf ein EEPROM.





.
Keine Interessen, kein Spezialwissen, keine persoenlichen Daten, keine Hobbies oder Vorlieben.

Aber: T-DSL..... sauschnell


Dieser Beitrag wurde 1 mal editiert, zuletzt von Fennec am 05.03.2015 - 16:49.
Beitrag vom 05.03.2015 - 16:47
Diesen Beitrag melden   nach weiteren Posts von Fennec suchen Fennec`s Profil ansehen Fennec eine private Nachricht senden Fennec zu Ihren Freunden hinzufügen zum Anfang der Seite
SupTom ist offline SupTom  
Themenicon   
23 Beiträge - Grünschnabel
Wenn Ich den Logger mit dem TTL Datenkabel am PC verbinde kommt die Kryptischen Zeichen ohne TTL Dk geht's

und das mit dem loop back am BTM funktioniert auch

laut einigen schaltplänen aus dem Netz kann es nur die 5, 6 oder 7

nach ausmessen und Sichtkontrolle müsste die 7 TxD und die 5 RxD sein
TxD geht noch zu dem Bauteil unten links (K1FA6 da habe ich nichts gefunden) und von dort zu dem Programmieranschluss

ich habe Kabel angelötet an 5, 7 / 5,6 / 6,7
ich habe die Leiterbahnen getrennt an die 5 komme ich nicht ran die sind drunter

unglücklich kein erfolg nur Kryptisch oder gar nix

ich werde es mit dem Modul v2.2 versuchen, da ist der Max schon drauf

den Schaltplan habe ich gerade gefunden da ist es die 7 TxD
http://www.mg-elektronik.de/thermo.htm

FENNEC lachend lachend lachend lachend

es geht,
mann ich hatte ne Lötbrücke auf dem BTM mini, nach dem ich ein anderes genommen habe, zack war alles da

Ich brauche eine größere Lupe glücklich die Dinger sind aber auch klein das war meine erste SMD aktion

ich brauche nur auf den Programmierstecker gehen da liegt TxD und RxD für einen USB Adapter an

Sch... ärgerlich ärgerlich ärgerlich ärgerlich geht wider nicht

irgend etwas stört der Empfang der Daten ist wieder unregelmäßig
ich bestell doch mal das Modul v2.2 mal sehen ob es damit besser geht






Dieser Beitrag wurde 2 mal editiert, zuletzt von SupTom am 06.03.2015 - 15:33.
Beitrag vom 06.03.2015 - 12:29
Diesen Beitrag melden   nach weiteren Posts von SupTom suchen SupTom`s Profil ansehen SupTom eine E-Mail senden SupTom eine private Nachricht senden SupTom zu Ihren Freunden hinzufügen zum Anfang der Seite
Fennec ist offline Fennec  
Administrator
1220 Beiträge - Hardcoreposter
Fennec`s alternatives Ego
Ich sag' doch das geht.
Ich wuerde allerdings den Pegelwandler auf dem Temperaturmodul ganz umgehen und das Beinchen vom Tiny abheben (geht mit einer dicken Naehnadel) oder Leiterbahn durchtrennen.
Wozu braucht das Ding eigentlich RXD ?

Probiere mal ob der mit dem Kabel direkt stabil laeuft.
Die Bluetooth Module sind eigentlich sehr zuverlaessig, wenn die Einstellungen stimmen. Je nach Firmware zicken die schon mal rum.

Es kann auch an der Betriebsspannung liegen,.wenn Du ein unsauberes Schaltnetzteil hast. Teste das mal mit Batterien oder sowas.



.
Keine Interessen, kein Spezialwissen, keine persoenlichen Daten, keine Hobbies oder Vorlieben.

Aber: T-DSL..... sauschnell
Beitrag vom 07.03.2015 - 19:23
Diesen Beitrag melden   nach weiteren Posts von Fennec suchen Fennec`s Profil ansehen Fennec eine private Nachricht senden Fennec zu Ihren Freunden hinzufügen zum Anfang der Seite
SupTom ist offline SupTom  
23 Beiträge - Grünschnabel
Hallo Fennec

VCC kann es nicht sein, da habe ich 9 Volt und 5 Volt Stabi für das BTM.
Über Rxd sagst du dem Logger was er machen soll, du kannst speichern und direkt ausgeben und noch ein paar Sachen mehr (steht bei dem blauen C).

Das Beinchen habe ich angehoben, da kommt alles Kryptisch. Es ist schwer nach zu vollziehen wie die Leiterbahnen verlaufen, es geht einer über einen R auf TxD und eine Bahn geht über den K1FA6.

Bei meiner Lochplatine habe ich ja das gleiche, mit MAX geht super und mit Pegelwandler 1 Transistor geht schlecht, weil es ja invertiert ankommt und der MAX gibt es ja mit dem richtigen Pegel aus, oder ?

Aber sag mal, macht der 74HC nicht das gleiche wie der MAX ?

Ich würde schon gerne wissen warum das nicht geht ärgerlich ärgerlich ärgerlich




Beitrag vom 08.03.2015 - 15:55
Diesen Beitrag melden   nach weiteren Posts von SupTom suchen SupTom`s Profil ansehen SupTom eine E-Mail senden SupTom eine private Nachricht senden SupTom zu Ihren Freunden hinzufügen zum Anfang der Seite
Fennec ist offline Fennec  
Administrator
1220 Beiträge - Hardcoreposter
Fennec`s alternatives Ego
Der 74HCT14 wandelt passt den Pegel von 5V TTL auf 3,3V TTL fuer das BTM an, eben damit das mit jedem 5V µC laeuft, also genau dafuer was Du da machen willst.
Das MiniBTM kannst Du nicht direkt an die RS232 anschliessen, dazu brauchst Du einen MAX232, weil das RS232 Protokoll auch negative Spannungen hat.

Hast Du das so angeschlossen ?



Edit by Admin Bildgroessen angepasst



.
Keine Interessen, kein Spezialwissen, keine persoenlichen Daten, keine Hobbies oder Vorlieben.

Aber: T-DSL..... sauschnell


Dieser Beitrag wurde 8 mal editiert, zuletzt von Fennec am 24.06.2015 - 00:11.
Beitrag vom 08.03.2015 - 18:24
Diesen Beitrag melden   nach weiteren Posts von Fennec suchen Fennec`s Profil ansehen Fennec eine private Nachricht senden Fennec zu Ihren Freunden hinzufügen zum Anfang der Seite
SupTom ist offline SupTom  
23 Beiträge - Grünschnabel
Ja das mit dem Pegel ist mir bekannt, das macht ja der MAX3232 auch von 5 V auf 3,3 V und 3,3V auf 5V.
Ich habe immer den 74HC dazwischen der Datenlogger bring ja auch 5 Volt

genauso habe ich das angeschlossen aber TxD und Rxd gekreutzt und auch ungekreutzt probiert


Dieser Beitrag wurde 1 mal editiert, zuletzt von SupTom am 08.03.2015 - 18:27.
Beitrag vom 08.03.2015 - 18:24
Diesen Beitrag melden   nach weiteren Posts von SupTom suchen SupTom`s Profil ansehen SupTom eine E-Mail senden SupTom eine private Nachricht senden SupTom zu Ihren Freunden hinzufügen zum Anfang der Seite
Fennec ist offline Fennec  
Administrator
1220 Beiträge - Hardcoreposter
Fennec`s alternatives Ego
Hast Du das wie oben angeschlossen ? Das klappte mit dem Bild nicht..

Zitat
Ja das mit dem Pegel ist mir bekannt, das macht ja der MAX3232 auch von 5 V auf 3,3 V und 3,3V auf 5V.



Genau das macht er eben nicht.

Der TTL Pegel wechselt zwischen 0 und 5V oder eben beim BTM222 von 0 auf 3,3V

Beim MAX232 / MAX3232 wechselt der Pegel. Eben RS232 Protokoll, zwischen 15V und -15V !



Quelle: Wikipedia.org

Edit by Admin Bildgroessen angepasst



.
Keine Interessen, kein Spezialwissen, keine persoenlichen Daten, keine Hobbies oder Vorlieben.

Aber: T-DSL..... sauschnell


Dieser Beitrag wurde 3 mal editiert, zuletzt von Fennec am 24.06.2015 - 00:12.
Beitrag vom 08.03.2015 - 18:42
Diesen Beitrag melden   nach weiteren Posts von Fennec suchen Fennec`s Profil ansehen Fennec eine private Nachricht senden Fennec zu Ihren Freunden hinzufügen zum Anfang der Seite
SupTom ist offline SupTom  
23 Beiträge - Grünschnabel
ja wie auf dem Bild, da bekomme ich das so rüber wie es sein soll, aber manchmal nicht stabil, da kommen immer nur die ersten zwei zeilen und die kommen andauernd

Templog 2.5 (C) 2012 Conrad Electronic SE
(Temp. in Grad Celsius)

und manchmal kommt alles

jetzt wo du es sagst mit dem RS232 Protokoll fällt es mir auch wieder ein

also müsste aus dem Tiny das RS232 Protokoll kommen das geht ja meiner meinung nach direkt vom Tiny über einen R direkt auf den TxD (ist halt schlecht zu sehen weil einige Leiterbahnen verdeckt sind) Anschluß, also wäre es das gleiche wenn ich das Beinchen hebe ?

und über den K1FA6 geht es auf den anderen Anschluß der kann über ein Programmierkabel an USB angeschlossen werden


Beitrag vom 08.03.2015 - 18:53
Diesen Beitrag melden   nach weiteren Posts von SupTom suchen SupTom`s Profil ansehen SupTom eine E-Mail senden SupTom eine private Nachricht senden SupTom zu Ihren Freunden hinzufügen zum Anfang der Seite
Fennec ist offline Fennec  
Administrator
1220 Beiträge - Hardcoreposter
Fennec`s alternatives Ego
Nein, der Tiny kann keine negativen Pegel, da muss ein Konverter a la MAX drauf sein. Kann also nur dieser K1FA6 sein.

RxD und TxD findest Du ja ganz einfach von diesem 4 Pin Sockel, der muss ja direkt an den AVR gehen.

Das ganze andere Geruempel einfach weg loeten oder Leiterbahn durchtrennen.

In der Beschreibung steht auch irgendwas von 7-14V. Wie funktioniert denn da die Spannungsregelung ?

Also das Dingen ist doch wirklich Krampf.

/Edit

Das liest sich aber ganz anders als wie Du schreibst, da kaeme nur kryptisches Zeugs, oder das beispiel von oben.

Zitat
ja wie auf dem Bild, da bekomme ich das so rüber wie es sein soll, aber manchmal nicht stabil, da kommen immer nur die ersten zwei zeilen und die kommen andauernd

Templog 2.5 (C) 2012 Conrad Electronic SE
(Temp. in Grad Celsius)

und manchmal kommt alles





.
Keine Interessen, kein Spezialwissen, keine persoenlichen Daten, keine Hobbies oder Vorlieben.

Aber: T-DSL..... sauschnell


Dieser Beitrag wurde 1 mal editiert, zuletzt von Fennec am 08.03.2015 - 19:24.
Beitrag vom 08.03.2015 - 19:21
Diesen Beitrag melden   nach weiteren Posts von Fennec suchen Fennec`s Profil ansehen Fennec eine private Nachricht senden Fennec zu Ihren Freunden hinzufügen zum Anfang der Seite
SupTom ist offline SupTom  
23 Beiträge - Grünschnabel
also wenn ich an TxD oder direkt an den Tiny gehe kommen diese Zeichen

Šú£•¿¯y­¿›Ÿ›¿yyyUSÒ
Šú£•¿¯y­¿›Ÿ›¿y!#7¿u'59#-9¿Yuå¯W5%­£¿-#¿q7¿y5'-§
­åås§#)-!#¿=5/'5#¿IŸ££‘E‹å埋¿Y­yUSÒ
Šú£•¿¯y­¿›Ÿ›¿y!#7¿uyyUSÒ

wenn ich an den 4 Pin Sokel gehe kommt manchmal das komplette Protokoll

Templog 2.5 (C) 2012 Conrad Electronic SE
(Temp. in Grad Celsius)

Funktion waehlen [0..7]:

0: Sprache/Language [d]
1: Messwerte anzeigen
2: Messwerte anzeigen und aufzeichnen
3: Aufgezeichnete Messwerte anzeigen
4: Dezimal-Trennzeichen [,]
5: ADC an [n]
6: ADC kalibrieren
7: Messintervall Sekunden [5]

(das sind die Einstellungen die über RxD gesendet werden können)

oder es kommen nur diese ersten zwei Zeilen

Templog 2.5 (C) 2012 Conrad Electronic SE
(Temp. in Grad Celsius)

und die kommen im Sekunden Takt

mit dem umbauen der Logger das ist zu aufwendig das wären 20 Stück

der ist erstmal Bein amputiert grosses Lachen , da habe ich ihn mal runter genommen die 6 ist RxD und die 7 TxD




Beitrag vom 08.03.2015 - 19:53
Diesen Beitrag melden   nach weiteren Posts von SupTom suchen SupTom`s Profil ansehen SupTom eine E-Mail senden SupTom eine private Nachricht senden SupTom zu Ihren Freunden hinzufügen zum Anfang der Seite
Baumstruktur - Signaturen verstecken
Seiten (3): (1) 2 3 weiter > vorheriges Thema   nächstes Thema

Gehe zu:  
Es ist / sind gerade 0 registrierte(r) Benutzer und 58 Gäste online. Neuester Benutzer: mucky
Mit 3733 Besuchern waren am 10.01.2015 - 05:53 die meisten Besucher gleichzeitig online.
Aktive Themen der letzten 24 Stunden | Foren-Topuser
 
Copyright © 2004/15 Herbert Boroske, Inc. All Rights Reserved.

Diese Webseite ist für den reinen privaten Gebrauch und nicht kommerziellen Bereich gedacht.

Seite in 0.07995 Sekunden generiert


Diese Website wurde mit PHPKIT WCMS erstellt
PHPKIT ist eine eingetragene Marke der mxbyte GbR © 2002-2012